beanstalkd

There is now a wiki page for beanstalk clients with a more up-to-date list of supported languages.

Or, make your own client API. It's easy! The 1.3 protocol doc gives a complete description of the beanstalk protocol.

Note: as of version 1.0 the protocol will remain compatible until beanstalkd 2.0. Any client written to work with a 1.x beanstalkd will also work, unchanged, with any later beanstalkd before 2.0.

You can find the bleeding-edge latest protocol.txt in git.